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Session 1: Configure Report Controls

Steps to Create a Report

1. Go to the ‘Create’ tab. Ensure the proper query is selected. In this case, FORMQUERYBUILDER is selected. Now,
click on the ‘Report’ button, which will generate a report based on that query.

2. The report for “formquerybuilder” is opened in Layout View.

3. Drag the fields by selecting them.

4. Right-click on the form output tab and ‘Save’.

5. Here we saved the form with the name “reportforstutab”. Till now, we are in Layout View.

6. Right-click on the report tab and select “Report View” to view the whole form in full mode.
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Steps to Sort fields in a report
1. Select a table or query that contains the records you want on the report. On the ‘Create’ tab, click ‘Report’.

2. Go to the ‘Design’ tab and select Layout View. Go to the report and select a column.

3. As you can see in the report, the data in the course id is un-sorted.

4. Right-click the column and click one of the sort options.

The values were placed in course id in the ascending order. That is the smallest to largest in manner.
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Steps to Group Fields
Steps to group the fields are:

1. Select a table or query that contains the records to be displayed in the report. On the ‘Create’ tab, click

‘Report’.

2. Go to the ‘Design’ tab and select Layout View. Go to the report and select a column.

3. Let us select ‘course id’.

4. Right-click on the column. Select the group on the ‘course id’ option.

5. The group on option is applied on ‘course id’.

6. Open the report in Report View.

7. The output of the report in Report View is as shown here. As you can see, the records are grouped by

‘course id’.
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Steps to Group and Sort Fields Using Report Wizard
1. Select a table or query that contains the records you want on your report. On the ‘Create’ tab, click ‘Report’.

2. Go to the ‘Design’ tab and select Layout View. Later, go to the report and select a column.

3. Click a column. Let us say ‘course id’. Go to the ‘Design’ tab.

4. Go to Report Wizard in the ‘Create’ tab.

5. When you click on Report Wizard, a new window box will be opened. The user will be asked to add fields.

6. The (>>) “double greater than” symbol allows the user to add all fields.

7. The “greater than” symbol allows the user to add a single row at a time. After selecting the desired fields,

click Next.

8. A new wizard will ask if any grouping levels are to be included.

9. The ‘Grouping Options’ tab will open a sub-window where the user can select the grouping intervals in

spaces.

10. Here the student address is added as another grouping level so that ‘course id’ is the main group, student

address a sub-group. Click ‘Next’.

11. A new options window will open asking the user to select a field to apply ‘sorting’. The student marks field

is selected here in the ascending order. And then click ‘Next’.

12. A new wizard asks about the layout of the form.

13. Select the landscape option and stepped layout.

14. Save the report and click ‘Finish’.

15. A report will be displayed in the print preview format.
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Steps to Group And Sort Fields In Layout View
1. Select a table in the ‘Navigation’ pane and click ‘Report’ in the create tab.

2. Now the table is opened as a report in the layout view.
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3. Click on the ‘Group and Sort’ option in the ‘Design’ tab. You will see buttons with add a group and add a sort

appear on the report.

4. Click on the group button and select one field to group the data.

5. Select ‘course id’.

6. The report is grouped on ‘course id’.

7. Apply sorting mechanism.

8. The data is sorted from the smallest to the largest.

9. So based on the ‘course id’ grouping, the student number field is sorted from the smallest to the largest.

The report is as shown here.

Note:We can sort the data from the largest to the smallest also.
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Steps to add report controls:
Steps to add report controls:

1.Go to the ‘Create’ tab. Select the ‘Blank Report’ option.
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2.Go to the ‘Design’ tab. Click on the ‘Views’ option and select Design View.

3.A blank report is opened.

4.Click on the ‘Tab’ option in the ‘Controls’ ribbon. Click on the grid lines of the report to add the tab.

5.A tab with two pages will be displayed.

6.Change the name of Page 2 in the property sheet by double-clicking on it.

7.A new name is added to the tab on Page 2.

8.Similarly, change the name of page one tab.

9.A new name is added.

10. To add one more page on the tab, right-click on the tab and select the ‘Insert Page’ option.

11. A new page is added to the tab. Repeating earlier steps, rename the page in the property sheet.

12. A new name is added to Page 3 as marks.

13. Go to the ‘Design’ tab. Select the ‘Add Existing Fields’ option.

14. The ‘Field List’ pane is added on the right side of the report window.

15. Select one table among the list. Drag a field from the field list area to the tab area.

16. Maths marks were added in the marks tab.

17. Add physics marks to the marks tab.

18. Later, select the student details tab. Add ‘student name’ and ‘course id’ by the drag and drop method.

19. Add student address in the student address tab.

20. Save the report and open it in Report View.

21. The output is displayed in rows. Use the scroll bar to view the whole form.

22. To view all the records, go to the ‘Print Preview’ tab and select the ‘More Pages’ option. The output is

displayed on multiple pages in a short manner.
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Session 2: Format Reports

Steps to Create a Multiple-Column Report

1.Open the report in Design View.

2.Select the ‘File’ menu and select the ‘Print’ option. Later, select Print Review.

3.Go to the ‘Page Setup’ tab. The ‘Page Setup’ dialog box appears. Click on the ‘Columns’ tab.
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4. Enter the appropriate settings. You will find a brief description of these settings. In the ‘Down, Then Across’
option, records are printed on each column and the columns run across the page. In the ‘Across, Then
Down’ option, records are printed across each row and the rows run down the page.

5.Click ‘OK’ after selecting either.

6. A warning message will be displayed as shown. It is because the number of columns is changed from one to
three. Click ‘OK’.

7.Output is displayed in three columns.

8.For a clear view, select the ‘One Page’ option.

9. The “Across, Then Down” option will print the records across each row and then the remaining rows move
down the page.

10. Go to the ‘Print Preview’ tab and select the ‘PDF’ format.

11. Click on ‘Exporting to PDF’, a warning message will be displayed.

12. ‘Publish on PDF or XPS’ window is opened. Print the copy or select the path to save the pdf.

13. A successful message appears. Then, click ‘Close’.

14. If you access the path, you can see the newly created PDF file.

15. To avoid an unclear vision of the form, go to the ‘Page Setup’ option.
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Steps to Change Report Orientation

1.Open the report in Design View.

2.Select the ‘File’ menu, then the ‘Print’ option. Later, select Print Preview.

3.Click the ‘Page Setup’ option. The ‘Page Setup’ dialog box appears.

4.Go to the ‘Print Options’ tab. Select top, bottom, left and right margins. Change the values and move to the
‘Page ‘tab.

5.In the ‘Page Setup’ box, select the ‘Page’ tab. Click ‘Portrait’ or ‘Landscape’ to change the paper orientation.
Also, change the paper size, if required.
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Steps to Modify Report Positioning

1.Select a table. Go to the ‘Create’ tab. Select the ‘Report’ option.

2.A report was created and viewed in the Layout View mode.

3. Select one table header in the report and drag the field as per the requirement. Then, the size of the table
header will be increased.

4.Open the report in Design View.

5.Select one whole column of the table as shown here. Let us consider Student number.

6.Drag the Student number column from the first position to the required position.
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7.Select the File menu, then ‘Print Option’. Later, select ‘Print Preview’.

8.You may notice that the Student number position is now changed.

9.Save the report.

10. Open the report in the Report View mode.

11. The updated report shows the Student number in the second column, which was originally in the first
column.
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Steps to Format Report Elements

1.Select a table. Go to the ‘Create’ tab and select the ‘Report’ option.

2.A report was created and viewed in the Layout View mode.

3.Select the values of the form.

4.Go to the text formatting ribbon. Select the options, such as font colour, font size and left, right or ‘justify’
alignment.

5.For instance, consider selecting font colour as “red” and font as “Adobe Gothic Std B”.

6.See the difference between the first field and the second field of the report.

7.For formatting fields, let us select the Student number field and go to the text formatting ribbon. Select the
‘Align left’ option.
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8.Now, see the report in the Report View mode.
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Sections of a Report

1. Report Header appears at the top of the first page and displays the report title.

2. Page Header appears at the top of every page and displays the headings for each column.

3. Detail Section appears between the page header and page footer. It displays the records from the table or
query.

4. Report Footer is optional. It appears on the last page of the report and displays summary information, such
as grand totals.

5. Page Footer appears at the bottom of every page and displays the page number and the total number of
pages.
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Steps to Add Header and Footer

Steps to Format Report Elements:

1. To insert information in report headers and footers, select the table and go to the ‘Create’ tab. Later, select
the ‘Report ‘option.

2. Now, the table is opened in Report View.

3. Open the report in Design View.

4. Right-click on the reports area, where reports were opened in Design View. Select the Report Header/Footer
option in the list.

5. See the report header at the top of the report.

6. See the report footer below the report.

7. Go to the ‘Design’ tab and click on the ‘Date and Time’ option. The ‘Date and Time’ functions were added.
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8. Expand the space of the report footer with a mouse, click the ‘Add Label’ box in the footer.

9. A label is added so that any information can be typed in the ‘Label’ field. Write some example text in the label
box.

10. Save the report by changing the name in the ‘Save As’ box and click ‘OK’.

11. Change to Report View from Design View.

12. The report is viewed with updated changes in Report View.
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Steps to Insert Images

1. To insert an image, select a table or a query that contains records for the report. Click ‘Report’ on the ‘Create’
tab.

2. Go to the ‘Design’ tab and select Design View.

3. Go to the ‘Format’ tab. And in the ‘Background’ ribbon, click on ‘Background Image’.

4. A list of frequently used images will appear. You may choose one from the list or click on ‘Browse’.

5. A new window will open. Select an image and click ‘Open’.

6. Image is applied to the report.

7. Click on the ‘Report’ tab and move to Report View.

8. The image is successfully added to the report background.
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Recap:

o A report consists of information that is pulled from tables or queries.

o To sort display data based on a specific field, right-click on the field from the report opened in Layout View.
Choose one of the sort options such as ascending or descending.

o To group data by a column, right-click on the column from the report opened in Layout View. Select the group
on option.

o You can sort and group fields using either Report Wizard or in Layout View.

o To add controls, open the report in Design View. Click on the required control and then click on the grid lines
of the report to add the control.

o Formatting a report involves changing its appearance or presentation, such as orientation, positioning of
elements, adding header, footer or images.

o To create a multiple-column report, “Down, Then Across” or “Across, Then Down” options are used.

o The ‘Page Setup’ box option is used for changing report orientation

o Field positioning can be modified by the click and drag action

o Use the ‘Text Formatting’ ribbon to modify font colour, font size and alignment of the elements on the report.
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o A report consists of sections that include Report Header, Page Header, Detail Section, Page Footer and Report
Footer

o Using the Background Image option, the image can be inserted into a report
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