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Session 1: Configure Form Controls

Forms, Bound Forms, Unbound Forms

A form is a database object used to create a user interface that displays live data from tables for easy process.

There are two types of forms:

Bound forms - Bound forms are connected to some underlying data source, such as a table, query or SQL

statement. They are to be filled out or used to enter or edit data in a database.

Unbound forms - Unbound forms are not connected to an underlying record or data source. They could be

dialog boxes, switchboards or navigation forms. They are used to navigate or interact with the database at

large, as opposed to the data itself.
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Steps to Create a Blank Form

The steps to create a blank form are:

1. Go to the ‘Create’ tab and click on the ‘Form’ option.

2. Another way to create a blank form is by using the ‘Form Wizard’ option.

3. Open the form wizard and select the required table. Click ‘Next’.

4. Select a suitable wizard and click ‘Next’.

5. Select the title of the form. You can rename it if you want. Finally, click ‘Finish’.
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Form Views

Let us learn the different form views available.

1. Form View is a normal view, where you can view, add and edit records. You can't modify the form's
structure in this view.

2. Layout View allows you to format and rearrange fields while displaying data.

3. Design View is used for in-depth modification and customisation of your form. Live data is not visible
as you are only working with the structure of the form.

4. Data Sheet, Pivot Table and Pivot Chart are the views that are available only for certain types of
forms.

5. Print View displays a form as it would look when printed.
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Components of Forms

The different components of a form are:
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<Labels> Labels display descriptive text, such as titles, captions or brief instructions. For example, student

number, name, student marks and so on.

<Controls> Controls are the parts of a form used to enter, edit or display data. Controls let you view and work

with data in the database application.

<Fields list> Fields list is the panel where a list of fields of a single table or multiple tables can be viewed.

<Navigation pane> Navigation pane is the group of a list of tables, forms or queries, which were created by a

user in the database application.
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Add a Field to Form, Move a Field, Delete a Field

The steps to add a field to a form are:

1. Go to the ‘Design’ tab.
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2. Click the ‘Add Existing Fields’ button on the ribbon.

3. The ‘Field List’ pane appears. Double-click the field you want to add. Or click and drag the field onto
the form.

4. Now, the form is added with the date of birth field.

5. Another way to add fields is to right-click on the field you want to add and select the ‘Add Field to
View’ option. Then, the selected field is added to the form.
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The steps to move a field are:

1. Consider the student table.

2. To move the field ‘Student marks’ from the third position to the fourth position, select the field.

3. Then, select the field and drag it to the fourth position.

4. The final output form will be displayed as shown here.
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The steps to delete a field are:

1. To delete a field, select the field in the form. Right-click on it. A drop-down list appears. Select the
‘Delete’ row.

2. See the output form. The layout is automatically adjusted.
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Control Types

The different control types are:
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Set Control Properties

The steps to set control properties are:
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1. Go to the ‘Create’ tab.

2. Select form option for student table. A form for the student table is displayed.

3. Go to the ‘Design’ tab and click on the ‘Add Existing Fields’ option. The ‘Field List’ pane will be opened.
Select the table from where you want to add one field. Let us set up a field for course ID from the
course table.

4. Double-click on the course ID field to add it to the form. From the ‘Design’ tab, select the combo box
from the controls list. Drag the option towards the last field in the form.

Now course ID is highlighted and a combo box wizard will be opened.

5. The wizard has two options. One is to get the combo box values from another table or query. The
second type is to get values from users. Let us select the first option and click ‘Next’.

6. The wizard will ask which table should the user provide the values for the combo box. Select the
source table or queries or both.

7. Later, select the required field from the list of fields. Click the greater than symbol and click ‘Next’.

8. Later, the combo box wizard will ask about the sorting order of the data in the list. Select the desired
order and click ‘Next’.

9. The combo box wizard will ask if it has to remember the value for later use. Choose an option and
click ‘Next’.

10. Later, label the combo box and click ‘Finish’. The course ID field will display new properties.
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Set Control Properties for Linked Tables

The steps to set control properties for linked tables are:

1. Go to the ‘Create’ tab in the forms group and click on ‘Blank Form’. An unbound form will be opened
with the name ‘Form1’.



8

2. Go to ‘Design View’ to add fields.

3. Form 1 is opened in Design View with several grids. On the ‘Design’ tab, click on ‘Property Sheet’.

4. On ‘Property Sheet’, click on the drop-down arrow. Make sure that the form is selected and then go to
the ‘Data’ tab.

5. On the ‘Data’ tab, click on the ‘TRIPLE DOT’ button. It will further open its own query builder.

6. Select the tables that contain the data. Click on the ‘Add’ button and then close this dialog box.

7. Now select the fields from both the tables and drag them to the query grid. Click ‘Save As’ and give
this query a name.

8. Query Builder for Form 1 is opened. Save the query builder with another name by clicking it on the
tab.

9. To save the query builder, go to the ‘Design’ tab and click on the ‘Save As’ option. Later, close the
query builder form.

10. Now, go to the ‘Navigation’ pane. Double-click on ‘Form query builder’ under the queries list. A table of
data will be opened. Later, go to the ‘Create’ tab and click on the ‘Form’ option.

11. A form for ‘Form Query Builder’ is opened with several fields, which we selected in the query grid at
the time of creating the query builder.

12. Right-click on ‘Form Query Builder’. Select the ‘Form View’ option to enter data into the form.

13. When we enter data in the form and save it, the values will be updated in the corresponding tables.
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Set Button Control Property

The steps to set button control properties are:

1. Select a table from the navigation pane. Select the ‘Create’ tab followed by the ‘Form’ option.

2. Open the form in the layout view. Right-click on the mouse and select the ‘Insert’ option. Later, insert
a space or row below the labels.

3. Select the button box from the ‘Design’ tab. Place the button in the marked area of the form. By
dragging the mouse, we can add a button to a form.

4. When adding a button, a button wizard will be opened showing several options.
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5. Apply the action to the button. For example, let us select ‘Record Navigation’. An action ‘Go to last
record’ might appear. That means, whenever we click on the button, the form will move to the last
record. Click ‘Next’.

6. Here, the user can select the text on the command button by clicking on the ‘Text’ option. If not, the
user can select the picture on the command button by selecting the picture option.

7. Later, select a meaningful name for the button. And click on ‘Finish’.

8. A new button will be added with the ‘Last record’ title on it. Later, save the form and the table.
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Set Form with Subform

The steps to create a subform are:

1. Go to the ‘Navigation’ pane and select the ‘Course’ table from the tables list. Note that the course
table is linked with the student table.

2. Go to the ‘Create’ tab. Select the ‘Form’ option. Then, a form along with the subform will be opened.

3. Here, the course ID is one and the course name is ‘BCA’. The output subform is displayed as shown.

4. Click on the record status bar to move to the next record. Then, you see the next form with a subform.

5. The first part is the form for the course table. The second part is the subform, which is related to the
‘student’ table.
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6. In the course table, the course ID is the primary key; in the student table, it is a foreign key.

7. By seeing the form and subforms, you can notice that the total number of students studying the ‘BCA’
course with ‘course ID 1’ is four.
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Themes for Forms, Add & Modify Form Labels

The steps to apply different colours, font sizes or alignments to forms are:

1. Go to the ‘Navigation’ pane. Select a table. Let us say the ‘student’ table. Later, go to the ‘Create’
menu and select the ‘Form’ option.

2. Open the form in the layout view.

3. Click on the ‘Design’ tab. Select the ‘Themes ‘option. Apply the desired theme by clicking on the
‘Themes’ option.

4. A new theme is applied to labels and text in the form. Compare the first form with the second form.
The font and style are changed.

5. Finally, let us see how to add or modify form labels.

The steps to add or modify form labels are:
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1. Open a table in Design View. Add a new name to the old label as shown here. Save the form. A new
label is added.

2. To resize, click and drag the mouse to resize the height or width of the control.

3. Compare the first slide with the second slide where the field size is varied.

4. You can also modify multiple form labels by selecting all controls at a time.
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Session 2: Format Forms

Forms, Modify Tab Order

When you use a form in an Access desktop database, you can switch between controls by pressing the ‘TAB’

key. You can specify the order in which the controls on a form respond to the ‘TAB’ key.

The steps to the modify tab order on forms are:

1. Open the form in ‘Design View’.

2. Click ‘Tab Order’ in the ‘Tools’ group.

3. To create a top-to-bottom and left-to-right tab order, click ‘Auto Order’, which is the default. To create

a custom tab order, click the selector for the control you want to move. Click and drag to select more

than one control at a time. Click ‘OK’.

4. Open the form in the Form View.

5. If we compare the tab order wizards, we can notice that the tab controls moved as per the custom tab

order.
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Sort Records by Form Fields

The steps to sort records by student names in a table from a form are:

1. Go to the ‘Navigation’ pane and go to the forms list. Select the form by right-clicking on it. Open the

form in Layout View.

2. On the ‘Home’ tab, select the ‘student name’ field for which we want to sort the records. Select the

‘ascending or descending’ option under sort and filter group.

3. The output will be displayed based on the values of student names starting from a to z or z to a

depending on the sorting order chosen.
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Modify Form Positioning

The steps to modify the form positioning are as follows:

1. To modify the form positioning, select the whole form by clicking on the square box on the top-left

corner of the screen. Drag the whole form to the right till the grey marker.

2. Now, see the output form in the ‘Form View’ mode. The whole form labels and controls are moved

from the left corner to middle.

3. To modify the data positioning, once again open the form in the layout view.

4. Go to the ‘Home’ tab and the ‘Text Formatting’ ribbon.

5. Select the centre option in the ‘Text Formatting’ ribbon. Notice that data in the controls were

positioned in the centre.

6. If you select the right option, the data in the controls are positioned to the right.

7. In the text formatting ribbon, users can select the desired colour also. Choose red for instance. The

whole form text is converted from black to red.
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Insert Information in Header and Footer, Insert Images on Forms

The steps to insert information in Header and Footer are as follows:

1. To insert information in the header or footer ribbon, open the form in ‘Design View’. Right-click on

‘Design Surface’ and select ‘Form Header or Footer’ from the shortcut menu.

2. Go to the ‘Design’ tab. Select date and time from the header or footer ribbon. Add the date and time in

the header section by clicking the left button in the header section.

3. Later go to the ‘Design’ tab. Select the ‘Design’ tab and choose the text box. Go to the form footer

area and drag the mouse button to add a text box in the footer area.

4. Then add some sample FORMULA in the text box using the data tab in the property sheet. In the

control source field, select the three dots button (…) and write an expression in the expression builder

wizard.

5. For example, write formula such as =[maths marks]+ [physics marks]. Click OK.

6. Now, see the text box in the form footer area. The formula is appended.

7. Now, save the form and open the form in the ‘Form View’ option.

8. As we can see in the text box, the result of two subject marks was displayed. The form has the header

with time and date and the footer with the sum of two subject marks.
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The steps to insert images are as follows:

1. Go to the ‘Design’ tab. Select date and time from the header or footer ribbon. Insert image in the
footer section, by clicking the left button in the footer section.

2. Select the image from the list and click ‘OK’.

3. Next, go to the form footer area and left-click on that area. Here, the image is added with high quality
and large in size. So, go to the property sheet and resize the width and height.

4. And open the form in Form View to see the updated form with headers and footers.
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Recap:
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o A form is a database object used to create a user interface that displays live data from tables for

easy process. There are two types of forms:

o Bound forms

o Unbound forms

o Bound forms are connected to some underlying data source, such as a table, query or SQL

statement. They are to be filled out or used to enter or edit data in a database.

o Unbound forms are not connected to an underlying record or data source. They could be dialog

boxes, switchboards or navigation forms. They are used to navigate or interact with the database

at large, as opposed to the data itself.

o <Labels> Labels display descriptive text, such as titles, captions or brief instructions. For example,

student number, name, student marks and so on.

o <Controls> Controls are the parts of a form used to enter, edit or display data. Controls let you

view and work with data in the database application.

o <Fields list> Fields list is the panel where a list of fields of a single table or multiple tables can be

viewed.

o <Navigation pane> Navigation pane is the group of a list of tables, forms or queries, which were

created by the user in the database application.

o When you use a form in an Access desktop database, you can switch between controls by

pressing the TAB key. You can specify the order in which the controls on a form respond to the

TAB key.
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