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Session 1: Create Macros

What is a Macro?

Macro

1. A Macro is a tool that allows you to automate tasks and add functionality to your forms, reports, and controls.

2. MS Access macros are built from a set of predefined actions, allowing to automate common tasks, and add
functionality to controls or objects.

Types of Macros

Data Macros

1. Data Macros work directly on the data stored in the Access database application

2. It is also used to add logic to events that occur in tables, such as adding, updating, or deleting data

UI Macros

1. UI Macros work on the user interface of the application

2. Act on the form and reports

3. It is attached to UI objects such as command buttons, text boxes, forms, and reports

4. Automate actions such as opening another object, applying a filter, starting an export operation, and so on
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Create a UI Macro
The steps to create a UI Macro:

1. Create a contacts database in datasheet view as shown here.

2. Create the contact list form from the underlying contacts table. Select the contacts table and go to create and

click More Forms under Forms.

3. More Forms displays a list of options. Click Datasheet.

4. Save it as Contacts List.

5. Create another form called Contact Form. To do this, select the Table Contacts.

6. Go to Create and click Form under Forms.

7. Resize the columns in the form and save it as Contacts Form.

8. To embed UI Macro. Go to Datasheet Form Tools and click Property Sheet under Tools.

9. Select the column Header.

10. A list of events will appear under Event tab. Select On Click option.

11. Choose the macro builder and click OK.

12. Action Catalog will appear with a list of Program Flow and Actions.

13. In the search box, type ‘open’. Select OpenForm option.

14. The OpenForm dialog box appears. Fill all these arguments.

15. Select Contacts Form from the list in the FormName tab.

16. In the View tab, select the option as Forms.

17. In the Where Condition tab, select ID from the list and select Forms. Select ID option from Contacts List form.

18. Select the Data Mode as Edit.

19. Select the Window Mode as Dialog.

20. Save the macro and update the property by clicking Yes button.

21. These are the properties we have set.

22. Click the ID as 5 in the Contacts List form to run the UI macro.

23. A Contacts Form Dialog box will appear with all the details pertaining to that ID.

24. Final result of the UI Macro.
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Data Macros
Steps to group the fields are:

 Data macros are managed from the Table tab while viewing a table in Datasheet view.

 Data macros do not appear under Macros in the Navigation pane.

Two types of data macros:

1. Event-driven data macros

 Event-driven data macros are triggered by table events such as add, update, or delete data

2. Named data macros

 Named Data Macros run in response to being called by name

 Names Data Macros are associated with specific tables, not with events

 It is also called any other data macro or standard macro
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Create an Event-driven Data Macro
The steps to create an Event-driven Data Macro:

1. In the Navigation pane, double-click the table to which you want to add the data macro.

2. On the Table tab, in the Before Events group or the After Events group, click the event to which you want to

add the macro. For example, to create a data macro that runs after you delete a record from the table,

click After Delete.

3. Click on any macro option. Click and drag DeleteRecord option on to the macro pane.

4. Type the Alias for deleting the record and select the action as DeleteRecord.

5. Save the changes by clicking save option.

6. Save the changes by clicking Yes button.

7. In the Navigation pane, double-click the table to which you want to add the data macro. Let us select

‘contacts’.

8. Click the table on which you want to apply before events and after events.

9. On the Table tab, in the Before Events group or the After Events group, click the event to which you want to

add the macro. For example, to create a data macro that runs after you insert a record from the table,

click After Insert.

10. Click on any macro option. Click and drag CreateRecord option on to the macro pane.

11. Type the Alias for creating the record and select the action as CreateRecord.

12. Select the table in which you want to insert a record, which in this case is ‘Contacts’.

13. Add alias to the table.

14. Type the name for the field and also the value.

15. Save the changes by clicking save option.

16. To use ‘After Update’, select after update under after events to set macro.

17. In the Navigation pane, double-click the table to which you want to add the data macro. Let us select

‘Contacts’.

18. Click the table on which you want to apply before events and after events.

19. On the Table tab, click After Update.
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20. Click on any macro option. Let us click and drag EditRecord option on to the macro pane.

21. Select the action from combo box to edit the record.

22. To edit a record, set the field name and value.

23. Type the name for the field and also the value.

24. Save the changes by clicking save option.
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Create a Named Data Macro
The steps to create a Named Data Macro are as follows:

1. To create a named data macro, go to Navigation pane, double-click the table to which you want to add the

named data macro.

2. On the Table tab, in the Named Macros group, click Named Macro.

3. Then click Create Named Macro.

4. Access opens the Macro Builder, where you can begin adding actions. To add a parameter, at the top of the

macro, click Create Parameter.

5. In the Name box, type a unique name for the parameter. This is the name that you use to refer to the

parameter in expressions.

6. Optionally, type a description for the parameter in the Description box. The description entered acts as a

tooltip. This helps you remember the purpose of the parameter.

7. Save the changes by clicking save option.

8. To save, type the macro name as DataMacro1 and click OK.

________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

________________________________________________________________________________

_________________________________________________________________________________

_________________________________________________________________________________

Create Macros
Steps to edit a Named Data Macro:
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1. To edit a Named Macro, click Edit Named Macro in Named Macro.

2. Edit the record and set alias name as Last Name.

3. Save the changes by clicking save option.

Steps to rename a Named Data Macro:

1. To rename a named data macro, click Table tab, followed by Named Macro, and Rename/Delete Macro.

2. Data Macro Manager dialog box will appear. Click the option as DataMacro1 and click close.

3. To rename, enter the new name and press ENTER on your keyboard.

Steps to delete a Data Macro:

1. To delete a data macro, in the Navigation pane, double-click any table to open it in Datasheet view.

2. Click Table tab, then Named Macro, and then Rename/Delete Macro.

3. Click Delete next to the data macro that you want to delete.

4. A dialog box will appear which displays message to delete the macro or not. Click Yes to delete.
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Test a Macro Using Single Step Mode
The steps to test a Macro using Single Step Mode:

1. To test a macro, right-click the macro in the Navigation pane, and then click Design View.

2. Your current macros will be displayed.

3. On the Design tab, in the Tools group, click Single Step. Click Run. If the macro is a new or edited macro, you
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will be prompted to save the macro before you can run it.

4. The Macro Single Step dialog box appears. This dialog box displays information about the macro and the

macro action, and the error number. A zero in the Error Number box means no error has occurred.

5. To carry out the action shown in the Macro Single Step dialog box, click Step.

6. To stop the macro and close the dialog box, click Stop All Macros.

7. To turn off single stepping and run the remainder of the macro, click Continue.
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Debug A Macro
The steps to debug a Macro:

1. To debug a macro, right-click the macro and click Design view option from the list of options.

2. Open the macro in Design view.

3. At the bottom of the macro, select Submacro from the Add New Action drop-down list.

4. In the box just to the right of the word Submacro, type a name for the submacro, such as ErrorHandler.
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5. From the Add New Action drop-down list that appears within the Submacro block, select the

MessageBox macro action.

6. Message box will appear under submacro.

7. In the Message box, type the text as shown.

8. At the bottom of the macro, select OnError from the Add New Action drop-down list.

9. onError action will be displayed.

10. Set the Go to argument to Macro Name.

11. In the Macro Name box, type the name of your error-handling submacro. In this example, ErrorHandler.

12. Drag the OnError macro action to the very top of the macro.

13. OnError action and a Submacro that is named ErrorHandler.

14. The OnError macro action is placed at the top of the macro. It calls the ErrorHandler submacro in the event of

an error.

15. The ErrorHandler submacro only runs if it is called by the OnError action. It displays a message box that

describes the error.
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Run A Macro
The steps to run a Macro:

1. Open the database2 from home tab.

2. This will open the database and your form will automatically appear. You can now enter a record in the form.
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Session 2: Modify Macros

Add Action To A Macro

The steps to add Action to a Macro:

1. The first step in adding an action is finding it in the Add New Action drop-down list or in the Action Catalog.
Select FindRecord option from the drop-down list. Browse for the action in the Action Catalog pane.

2. Access searches both the macro names and their descriptions for the text you enter.

3. Select an action in the Add New Action list.

4. Drag the action from the Action Catalog to the macro pane. An insertion bar appears to show you where the
action will be inserted when you release the mouse button.
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5. If a Group, If, Else If, Else, or Submacro block is selected in the macro pane, Access adds the new action to that
block. If no action or block is selected in the macro pane, Access adds the new action to the end of the macro.

6. Most macro actions require at least one argument. View description of each argument by selecting the action
and then moving the pointer over the arguments.

7. Select the form name as Contacts Form from the list of form names.

8. To view the form in Design, Print Preview, Datasheet, and so on. Select Form from the list of views.

9. Type the condition from the list of conditions in Where Condition text box.

10. Select the data mode as Edit from the list of options.

11. To save your macro, choose the save option.

12. Save the changes by clicking Yes button.

13. After saving the arguments, the OpenForm will look like the below image.
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Move/Delete An Action

The steps to move/delete an Action:

1. Actions are executed in order, from the top to the bottom of the macro. To move an action up or down in the
macro, drag the action up or down to where you want it.

2. Select the action, and then press CTRL + UP ARROW or CTRL + DOWN ARROW.

3. To delete an action, select it and then press the DELETE key. Alternatively, you can click the Delete (X) button
on the right side of the macro pane.
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Recap:

o A Macro is a tool that allows you to automate tasks and add functionality to your forms, reports, and controls

o There are two types of data macros: event-driven data macros and named data macros

o Even-driven data macros are triggered by table events, such as add, update, or delete data

o Named data macros are associated with tables and run-in response to being called by name

o If there is a problem getting a macro run, you can use single step mode to get to the source of the problem

o Macros can be modified by setting actions to macros

o Actions can be added from the Add New Action drop-down list or using the Action Catalog

o Macros can contain multiple submacros
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