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Session 1: Create and Run Queries

What is a Query?

Queries

1. A query can either be a request for data results from your database or for action on the

data or for both.

2. Select queries are queries that are used to retrieve data from a table or to make calculations.

3. Action queries are queries that can add, change or delete data.

Uses of Queries

1. Answering simple questions, performing calculations and combining data from tables.

2. Queries can be used to filter particular information from a table’s data.

3. Queries can also be used to supply data from a report.

Save Queries

1. A query just pulls data out of tables and puts it in query datasheets. Query does not store data.

2. Adding or changing data, results in query changes.
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Create and Run Queries
The steps to save a query are:

1. Right-click on the ‘Query’ tab.

2. Select the ‘Save’ icon.

The steps to run a query in Access that has been saved:

1. Select the query to run.

2. Press ‘Enter’.

3. Alternatively, double-click the name of the query.

4. Accept the warning in the dialogue box.

5. The query runs automatically.

The steps To run a query in Access from the query’s Design view:

1. Open a query in Query Design View.

2. Click the ‘Design’ tab in ‘Query Tools’.

3. Click the ‘Run’ button in the ‘Results’ button group.
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Steps to Create Select Queries Using Wizard
The steps to create select queries using wizard are:

1. Select the ‘Create’ tab.

2. Select ‘Query Wizard’. A query wizard box will be opened.

3. Select the ‘Simple Query’ option and click ‘OK’.

4. Select the table from the list of tables.

5. Add the available fields you want to the selected fields.

6. Select ‘Next’.

7. The desired fields are added by clicking the greater than symbol to add one or more fields.

8. Choose to open the query in Datasheet View or modify the query in Design View and then
select ‘Finish’.
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Steps to create a Select Query using Query Design
The steps to create select queries using query design are:

1. Open the ‘Access’ database and select the ‘Create’ tab.

2. Click on the ‘Query Design’ tab.

3. Under the ‘Tables’ tab on the ‘Show Table’ dialog, double-click on the ‘Artists’ table and then select
‘Add’ to close the dialog box.

4. Add some fields, such as ArtistId and ArtistName to the query grid. Select the sorting option, if
necessary.

5. Run the query and you will see only these fields as the query result.

6. The query is executed.

7. The output of the table is displayed based on the criteria selected. After the query execution, ArtistId is
in descending order.
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Steps to create a Select Query Using Multiple Tables
The steps to create select queries using query Multiple Tables are:
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1. Select two tables by clicking on the ‘Query Design’ option as shown above.

2. Select the required fields from the two tables by double-clicking on the table portions.

3. After selecting the required fields in the query grid, click on the line where the two tables are joined.

4. A ‘Join Properties’ wizard will be opened, where the user can select the left and right table names and
the corresponding column names.

5. Go to the ‘Design’ tab and click on the ‘Run’ option to run the query.

6. The query is executed.

7. The query is executed and the output is displayed.

8. Now, right-click on the ‘Query One” tab and save it with an alternate name.
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Introduction to Crosstab Queries
Crosstab Queries
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1. Crosstab queries are used to cross-reference grouped data and summarise those groupings in a
meaningful way.

2. Data retrieval queries are used primarily for reporting purposes.

3. Crosstab queries can pivot aggregated row data into a columnar format.

4. Required data to be aggregated in some fashion.

5. Provide results in a format similar to spreadsheets.

6. Crosstab queries represent meaningful data in columns rather than in rows.
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Steps to Create Crosstab Queries
The steps to create crosstab queries are:

1. Click on the ‘Create’ tab in the ribbon and click ‘Query Design’.

2. Select each table that is required in the query. Click ‘Add’ to add it to the query.

3. Once all the tables are added, click ‘Close’ to close the dialog box.

4. Open the ‘Design’ tab and click ‘Crosstab’ in the ribbon. This switches the query to a crosstab query.

5. Changes in the options in the bottom query pane when it is in crosstab mode. The
Total and Crosstab rows appear and the Show row disappears.

6. Double-click a field in the top pane to make it appear in the bottom pane.

7. Some Access defined functions like the Format () function to display only the month portion of
the Order Date. Specify the format as we want the month to appear in "mmm" format as in Jan, Feb,
Mar and so on. Also use the Sum () function to perform a calculation on Unit Price, Quantity
and Discount fields. The query is executed and the output is displayed.
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Introduction to Parameter Queries
Parameter Queries:

Sounds incomplete.

Rewrite the sentence

Comment[Microsoft Office User1]:
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1. Parameter Queries retrieve information in an interactive manner prompting the end-user to supply
criteria before the query is run.

2. While creating parameter queries, you can specify what type of data a parameter should accept.

3. It is very important to set the data type for numeric, currency or date/time data.
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Create Parameter Queries
1. To create a parameter query is to set the query's criteria. In the section at the bottom of the ‘Access’

window, change any of the following values for the selected, that is, checked columns.
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2. In the ‘Field’ tab, type the name of a column to replace the selected column with a new one. You can
also click the drop-down arrow to see all available columns in the current table.

3. Select the ‘Table’ option. You can click the drop-down arrow to see a list of available tables in the
document.

4. Select the ‘Criteria’ tab. Add formulas or information to filter the data displayed by the query. For
example, you might type in >’1’ to show all column values that are greater than 1.

The steps to create parameter queries are:

1. Select the design view. Select the Student Course query (Stu_Course).

2. Select the field to be displayed when the query is running.

3. Select the table from which the data is queried.

4. Select the ‘Criteria’ tab. Enter Course Name within square brackets. This indicates that we ask the user
to input the parameter on which to query.

5. Execute the query. When the query is executed, the dialog box to input the course name appears.
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Steps to Append Command
The steps to append data from one table to another are:

1. Go to the ‘Design’ tab. Select the ‘Query Design’ option. Select one table as per the user requirement.
For example, STUDENTTABLE has been selected here.

2. Go to the ‘Query’ grid and select the desired fields like the table name, sorting option, and criteria as
greater than or equal to 108. In action queries, the user can select the criteria as per the
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requirements.

3. Go to the ‘Design’ tab.

4. Select the ‘Append’ option. The ‘Append’ dialog box will be opened.

5. In the ‘Append’ dialogue box, select the table in which the user has to append the output. In this
example, a copy of STUDENTTABLE has been selected.

6. Click ‘OK’ and run the query.

7. After running the query, a message will be displayed that some rows were appended.

8. Output table copy of STUDENTTABLE. Two rows were appended from the student table where the
criteria matched.
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Steps to Update Command
The steps to execute the update command are:

1. Go to the ‘Query Design’ option under the ‘Create’ tab.

2. The ‘Show Table’ wizard will be opened. Select the ‘STUDENTTABLE’ option.

3. After selecting the ‘Update’ option, notice that there are new changes in the query grid. You will see
that the ‘Update’ option is present in the query grid.

Sounds incompleteComment[Microsoft Office User2]:
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4. Run the query. You will get a dialog box to confirm the updates. Click ‘Yes’.

5. Go to the ‘Navigation’ pane and select STUDENTTABLE. Select ‘Open’ to view the updated table.

6. After saving the updated query, right-click on the ‘Query’ tab and check for the SQL View option. You
will see the updated query syntax as shown here.

7. In SQL View, the query is in ‘general English’ as language. We can also change the student address to
‘Madras’ where the address is ‘Chennai’ by updating the query.
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Steps to Make Table Command
The steps to execute the make table command are:

1. Open the ‘Create’ tab and select ‘Query Design’.

2. The ‘Show Table’ window opens.

3. Select the table from the given list of tables.

4. Go to the ‘Query’ grid and add the fields as per the requirements.
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5. Go to the ‘Design’ tab and click on the ‘Make Table’ option. A ‘Make Table’ dialog box opens.

6. Enter the table name in the ‘Table Name’ field and choose to create the table in this current database
or another database. Here we selected the current database. Click ‘OK’.

7. Select the ‘Run’ option under the ‘Design’ tab.

8. A warning message will be given by the database whether to paste the rows into a new table or not.

9. Click ‘Yes’ to proceed.

10. A new table named studtub has been created. You can see this table in the navigation pane.

11. Right-click on the new table and open the table to see the contents.
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Steps to Delete Command
The steps to execute delete command are:

1. Go to the ‘Design’ tab.

2. Click on the ‘Query Design’ tab. The ‘Show Tables’ window will be opened.

3. Select the studtab table and click Add button.

4. Select the fields which you want to delete from the table. Here, we have selected all the fields.

5. To see the query of Delete, right-click on the ‘Query’ tab and select SQL View. The query is displayed.

6. Click ‘Run’. The query will be executed.

7. A warning message will be displayed that the rows in the table will be deleted. Click ‘Yes’ to proceed.
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8. Now, the table is available with new rows.
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Session 2: Modify Queries

Steps to Add, Hide and Remove Fields in Queries
Steps to hide a query field:

1. To hide a query field in MS Access:

2. Open the query that contains the field to hide.

3. Switch to Design View from the ‘Access’ toolbar.

4. In the grid, uncheck the checkbox in the SHOW: a row of the field which you want to hide.

5. Click the ‘SAVE’ option from the ‘Access’ toolbar to save the changes.

Steps to add a query field:

1. To add a query field in MS Access: Open the query and switch to Design View.

2. Locate the field you want to add. Click the checkbox in the ‘Field’ option.
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3. Now, select the desired field option.

4. Run the query to view the updated query.

Steps to remove a query field:

1. To remove a query field in MS Access: Open the query and switch to Design View.

2. Locate the field to be deleted.

3. Click on the desired field option and select the field.

4. Now, right-click on the selected field. In this case, it is Date of Birth. Select the ‘Cut’ option.

5. The selected field will be deleted in the query. Save the query.
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Steps to Sort Data within a Query

Method 1:

1. Select a field in the query by which you want to sort.

2. Click the ‘Home’ tab on the ribbon and locate the ‘Sort & Filter ‘group.

3. Sort the field by selecting the Ascending or Descending command.

4. The table will now be sorted by the selected field.

Method 2:

1. Select the query.

2. Open the Design View.

3. Click the ‘Sort’ option on the field where the sorting needs to be done.

4. Execute the query.
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Steps to Filter Data within Queries
1. Go to the ‘Navigation’ pane.

2. Select the query and right-click on it.

3. Select Design View and run the query.

4. A query is executed and the output is displayed under the ‘studquery’ tab.

5. Go to the ‘Home’ tab and check for the ‘Filter’ option.

6. Go to the ‘Advanced’ filters.

7. Select the field Student number, go to the ‘Selection’ option in filters and click on it.

8. A filter is applied on the table where data in the table is obtained after query execution.

9. Similarly, filtering can be applied to the remaining fields in the table, such as Student name as well as
Student address.

10. As Student name and Student address fields store the text values, the text filters can be applied.
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11. To apply the text filters on the ‘Contains’ option. A dialog box will appear where the filtering text will
be supplied.

12. Click ‘OK’.

13. The query and filters will be executed and the output will be displayed as shown with two fields in
filtering.
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Steps to Format Fields within Queries
1. In Design View, select the field you want to format.

2. Click on the ‘Property Sheet’ button on the ‘Design’ tab.

3. The ‘Property Sheet’ appears.

4. Click the ‘Format’ box in the ‘Property Sheet’, you can adjust the formatting for the fields.

5. Type how you want the field to be formatted.
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Recap:

o A query is a request for data results or for action on data or both.

o The various queries that can be created in MS Access are:

- Simple Select Query

- Action Query

- Crosstab Query

- Parameter Query

- Multi-table Query

o Select queries are used to retrieve data from a table or to make calculations.

o Action queries can add, change or delete data from multiple tables at one time.

o Crosstab queries are used to cross-reference grouped data and summarise those groupings in a meaningful
way.

o Parameter queries are used to retrieve information in an interactive manner.

o Multi-table queries can combine information from multiple tables and give the result based on the criteria
selected.
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o In MS Access, queries can be modified by:

• Adding, hiding and removing fields in queries

• Sorting data within queries

• Filtering data within queries

• Formatting fields within queries
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