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Session 1: Create and Format Tables 

 

Steps to Create Excel Tables from Cell Ranges 

A table is a powerful feature to group your data together in Excel. It is a specific set of rows and columns in a 

spreadsheet. Tables make your Excel spreadsheet much easier to use, share and update. You can have 

multiple tables on the same sheet. 

 

The steps to create tables from cell ranges are as follows: 

 

 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 
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Applying Table Styles 

 

A table style is a collection of table formatting attributes, such as table borders and row and column strokes 
that can be applied in a single step. 

The steps for applying predefined styles to a table are as follows: 

 

 

 

 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 
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Creating or Integrating a Dataset as Table 

The first step to format a table is to create or integrate a dataset that will be needed for designing the table. 

 

The steps for integrating a dataset are as follow: 

 

 

 

 

 

 

 

 

 

 

 

 

__________
__________

_____________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 
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Formatting a Dataset as Table 

The steps for formatting dataset are as follows: 

 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 

_________________________________________________________________________________ 
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Steps to Create and Format Tables 

 

The steps for choosing a predefined table style are: 

 

 

 

 

 

The steps for creating a custom table style are: 

 

 

 

 

 

 

 

 

 

 

 

The steps to convert tables into cell ranges are: 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

1. Select any cell within the table or range of cells  

2. On the Home tab, click Format as Table 

3. Select the style of your choice for the table 

1. 1. Select any cell within the table or range of cells  

2. On the Home tab, click Format as Table 

3. Click New Table Style to create your own table style 

4. Click the options from the Table Elements as per your 

preferences 

5. Click Format 

• Choose the specifications under the Format button 

• Click OK 

• Click the custom style and it will be applied to the table 

Method 1:  

1. Click anywhere in the table 

2. Go to Table Tools > Design on the Main Menu 

3. In the Tools group, click Convert to Range 

Method 2:  

1. Right-click on the table 

2. Then, in the shortcut menu, 

click Table > Convert to Range 
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Session 2: Modify Tables 

Steps to Add or Remove Table Rows and Column using Resize Command  

You can easily add or remove table rows and columns on the Excel table in your worksheet.  

 

The steps to add table rows and columns using the Resize command are as follows:  

 

 

 

 

 

 

 

The steps to add only the columns are as 

follows:  

The steps to add only the rows are as follows: 

 

 

 

 

 

 

 

 

The steps to delete a table row or column are as follows: 

 

 

 

 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

1. Click anywhere in the table. 

2. Click Table Design > Resize Table. 

3. Select the entire range of cells you want your table to include. 

4. Press OK. 

1. Click anywhere in the column where you 

want to insert a new column. 

2. Choose Insert Columns from the menu 

bar. 

1. Click anywhere in the row below where 

you want to insert the new row. 

2. Right-click and choose Insert from the 

shortcut menu. 

3. Choose Entire Row. 

4. Click OK. 

1. Select one or more table rows or table columns that you want 

to delete. 

2. On the Home tab, in the Cells group, click the arrow next 

to Delete. 

3. Click Delete Table Rows or Delete Table Columns. 
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Alternative Way to Add/Insert a Row or Column 

 

The steps to add a row are as follows:  

 

 

 

 

 

The steps to add a column are as follows:  

 

 

 

 

 

The steps to insert a row or a column are as follows: 

 

 

 

 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

Alternative way to add a row: 

1. Select any cell within the row.  

2. Go to Home > Insert > Insert Sheet Rows. 
3. You can also right-click the row number and then select Insert. 

Alternative way to add a column: 

1. Select any cell within the column.  

2. Go to Home > Insert > Insert Sheet Columns. You can also 
right-click at the top of the column and then select Insert. 

Alternative method to insert a row or a column:  

1. Select a row/column 

2. Right-click on the mouse 

3. Click Insert 
4. Row/Column will be inserted 
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Steps to Configure Table Style Options 

 

The New Table style pop-up box in an Excel worksheet has table elements like: 

1. Whole Table 

2. First Column Stripe 

3. Second Column Stripe 

4. First Row Stripe 

5. Second Row Stripe 

6. Last Column 

7. First Column and so on 

 

The steps to apply formatting options are as follow: 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 
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Session 3: Filter and Sort Table Data 

Filter in Excel 

Filter is a method or tool that is used to show only certain amount of information from selected data. 

 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 
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______________________________________________________________________________________ 

Filter Records and Modes of Filtration 

 

The steps to filter data are as follow: 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 
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Sort Data by Multiple Columns 

 

Sorting data in MS Excel helps rearrange the rows based on the contents of a particular column.  
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Sorting Using Sort Button 

 

You can sort the data using the Sort button. 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 
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______________________________________________________________________________________ 

______________________________________________________________________________________ 

Multiple Level Data Sorting in Excel 

 

In most of the cases, you need to sort a single column. But in some cases, there may be a need to sort two 
columns or more than two columns. In such cases, you can use Multi-level sorting. 

 

The steps to perform multi-level sorting using the dialog box are as follows: 

 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

______________________________________________________________________________________ 

 

Recap: 
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o A table is a powerful feature to group your data together in Excel. It is a specific set of rows and 

columns in a spreadsheet. Tables make your Excel spreadsheet much easier to use, share and 

update. You can have multiple tables on the same sheet. 

o A table style is a collection of table formatting attributes, such as table borders and row and column 
strokes that can be applied in a single step. 

o You can easily add or remove table rows and columns on the Excel table in your worksheet.  

o The New Table style pop-up box in an Excel worksheet has table elements like: 

• Whole Table 

• First Column Stripe 

• Second Column Stripe 

• First Row Stripe 

• Second Row Stripe 

• Last Column 

• First Column and so on 

o Filter is a method or tool that is used to show only certain amount of information from  

selected data. 

o Sorting data in MS Excel helps rearrange the rows based on the contents of a particular column.  

o In most of the cases, you need to sort a single column. But in some cases, there may be a need to 
sort two columns or more than two columns. 

 

 


